Sikkerhed.

SUDO

Der er fundet et problem med sudo. Læs mere her

Hvordan udnytter jeg denne fejl? Bare Sudo bruger-id -1 eller 4294967295
Sårbarheden, der spores som CVE-2019-14287 og opdaget af Joe Vennix fra Apple Information Security, handler mere om, fordi sudo-værktøjet er designet til at lade brugerne bruge deres egne login-adgangskoder til at udføre kommandoer som en anden bruger uden at kræve deres adgangskode.

Hvad der er mere interessant er, at denne fejl kan udnyttes af en angriber til at køre kommandoer som root blot ved at specificere bruger-ID “-1” eller “4294967295.” Det skyldes, at funktionen, der konverterer bruger-id til dens brugernavn forkert, behandler -1 eller dens usignerede ækvivalent 4294967295, som 0, hvilket altid er bruger-id for rodbruger.

 

sudo def

 

Det er muligt at udføre sudo komandoer. Du kan prøve dette eks.

Det vil give UID 0 som er root.

sudo -u#-1 id -u 

0

Efter patch

unable to initialize policy plugin


Linux brugere pas på! CVE-2019-12735.

Product: Vim < 8.1.1365, Neovim < 0.3.6
Type:    Arbitrary Code Execution
CVE:     CVE-2019-12735
Date:    2019-06-04
Author:  Arminius (@rawsec)

Patch vi/vim Så hurtigt som muligt.

Beskrivelse af hack.

https://github.com/numirias/security/blob/master/doc/2019-06-04_ace-vim-neovim.md

 


Alle versioner af container-softwaren Docker har fejl.

Update din docker installation hurtigst muligt.

Kernen i hullet er FollowSymlinkInScope-funktionen, som er sårbar overfor basale TOCTOU-angeb. Funktionen har til formål at udregne en given filsti på en sikker måde, ved at behandle processerne som om de befandt sig inde i en Docker-container.

Den udregnede filsti bliver ikke brugt med det samme, men rundsendes en smule og anvendes lidt senere. En angriber kan udnytte dette tidsgab og tilføje en filsti, som er et symbolsk link (filhenvisning), der efter udregning kan ende med at pege på værtens filer med rod-privilegier.


 

Eller “The GHOST Vulnerability,” Ghost bliver den kaldet fordi det er gethostbyname() funktionen i glibc som er en del af alle linuxer typer, som har denne fejl. Hvis du køre en linux server på nettet så patch den som du plejder. Husk serveren skal rebootes. Fordi alle processer som bruge det skal genstartes. Der er en patch til de fleste linux systemer ude nu. Du kan køre denne test for at se om du skal patche din server.

$ php -r ‘$e = “0”;for($i = 0; $i < 2500; $i++){ $e = “0$e”; } gethostbyname($e);’ Segmentation fault

Mere info her


Linux.BtcMine.174


Ny Linux-‘virus’ graver efter kryptovaluta, stjæler root-passwords og sætter antivirus ud af spillet.

Den prøver også at installere sig på server som har ssh og du har være på.

Du kan læse meget mere her

 

 


Buffer Overfload i vlc Quichtime

Buffer Overfload i vlc Quichtime IMA filer.

Date              : June 2016
Affected versions : VLC media player 2.2.3 and earlier
ID                : VideoLAN-SA-1601
CVE reference     : CVE-2016-5108

Du kan læse mere her http://www.videolan.org/security/sa1601.html

 

0